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What's New
Feature Specifications for all features can be found on the OSMF Open Source site:

http://sourceforge.net/adobe/osmf

Supporting alternate audio tracks in HTTP Dynamic Streaming videos

OSMF supports multiple language tracks for an HTTP dynamic streaming video, without requiring
duplication and repackaging of the video for each audio track. This “late” binding of an audio track to a
video stream allows content publishers to support multiple language tracks, even after the initial
packaging of a video asset. Publishers don't have to duplicate the initial asset or repackage the asset to
play it with an alternate language track. They can simply provide multiple audio tracks for a given video
stream. Viewers can then choose to play an alternate audio track for the video.

Note: This Sprint drop supports alternate audio tracks only in VoD scenarios. Using alternate audio
tracks in a LIVE scenario is subject to the limitations described in the “Known Issues” section.

Support for starting from LIVE point in DVR scenarios

With previous versions of OSMF, the playback in a LIVE with DVR scenario started from the moment
when the DVR recording was initiated. This default behavior was changed in the current Sprint so that
the playback will always start from the LIVE point.

Bug fixes for this sprint

e http://bugs.adobe.com/jira/browse/FM-1310 - [Late binding audio] No audio output for VOD or
LIVE alternate audio tracks

e http://bugs.adobe.com/jira/browse/FM-1301 - [Late binding audio] Holding and dragging the
scrub bar causes a RTE

e http://bugs.adobe.com/jira/browse/FM-1293 - Playback of LIVE with DVR support content does
not start

e http://bugs.adobe.com/jira/browse/FM-1289 - Seek to live part of the DVR HDS stream doesn't
work




Notes

http://bugs.adobe.com/jira/browse/FM-1288 - Seeking inside a DVR HTTP stream throws a 2029
error

http://bugs.adobe.com/jira/browse/FM-1287 - Seeking outside buffer length leads to playback
freeze

http://bugs.adobe.com/jira/browse/FM-1280 - [Late binding audio] Video playback stutters
when there is a big difference between the video and audio packet data size
http://bugs.adobe.com/jira/browse/FM-1275 - [Late binding audio] Switching between
alternate audio tracks at intervals smaller than 4,5 seconds ignores the last switch change
http://bugs.adobe.com/jira/browse/FM-1274 - [Late binding audio] Switching back to original
media (audio + video) doesn't work after having switched to an alternate audio track
http://bugs.adobe.com/jira/browse/FM-1253 - [Late binding audio] When using media
individually packaged with different segment and fragment size switching to use an alternate
audio track the playback freezes and the browser hangs
http://bugs.adobe.com/jira/browse/FM-1248 - [Late binding audio] Playback of a f4m file that
has the main media shorter than the alternate audio track being used does not achieve
complete playback of the longest track

If StageVideo mode is enabled and a video resource is being associated with a smaller container,
make sure that the scale mode will not be set to ‘none’, otherwise, the video will not be clipped
according to the containers dimensions (this is the expected behavior).

Getting Started Instructions

Using OSMF with Flash builder 4 and Flex 4.5 SDK

Download the latest flex 4.5 sdk from the following link and unzip to .../Adobe Flash Builder
4/sdks/4.5.0
http://opensource.adobe.com/wiki/display/flexsdk/Download+Flex+Hero

Add the sdk to your workspace in Flash Builder 4 (Project/Properties/Actionscript Compiler /
Configure flex SDKs... /Add and select the unzipped folder)

Change default SDK version to Flex 4.5.

In your project properties, under Adobe Flash Player options, select “Use a specific version” and
choose 10.2.0.

Make sure the additional compiling arguments are containing: “-swf-version=11 -define
CONFIG::LOGGING true -define CONFIG::FLASH_10 1 true -define CONFIG::PLATFORM true -
define CONFIG::MOCK false”

A description of theses parameters:

- swf-version : required for stageVideo support

- CONFIG::LOGGING : configures the framework to send log traces, (recommended to be set
to false for release builds)



- CONFIG::FLASH_10_1 : makes the Flash Player 10.1 features (DRM, HTTP streaming)
available

- CONFIG::PLATFORM and CONFIG::MOCK control the mocking of stageVideo for unit tests.
They are usually in opposition (one true, the other false). To use stageVideo, please use the
above recommended configuration; to run unit tests, please negate the values.

6. You need to remove the older version of OSMF that is shipped with Flex 4.5 SDK, select File >
Properties > Flex Build Path > Library path, select osmf.swc under Flex 4.5 SDK on the Library
Path panel, and click the Remove button.

Using OSMF with Flash builder 4 and Flex 4.1 SDK

1. Flash Builder 4 users are recommended to change default SDK version to Flex 4.1.

2. Ifyou are using flex 4.1 sdk, you must update playerglobal.swc that is shipped with flex 4.1 sdk.
To do so, follow the below steps.
2.1Download playerglobal.swc from the following link
(http://download.macromedia.com/pub/labs/flashplatformruntimes/flashp
layerie-3/flashplayer10-3 playerglobal 052011.swc) and copy it to the
following folder: .../Adobe Flash Builder 4/sdks/4.1.0/frameworks/libs/player/10.1
2.2 If you have created 10.3 folder to copy the playerglobal.swc (.../Adobe Flash Builder
4/sdks/4.1.0/frameworks/libs/player/10.3), do the following.
In your project properties, under Adobe Flash Player options, select “Use a specific
version” and choose 10.3.0.

3. Make sure the additional compiling arguments are containing: “-define CONFIG::LOGGING true -
define CONFIG::FLASH_10_1 true -define CONFIG::PLATFORM true -define CONFIG::MOCK false”

A description of theses parameters:

- CONFIG::LOGGING : configures the framework to send log traces, (recommended to be set
to false for release builds)

- CONFIG::FLASH_10_1 : makes the Flash Player 10.1 features (DRM, HTTP streaming)
available

- CONFIG::PLATFORM and CONFIG::MOCK control the mocking of stageVideo for unit tests.
They are usually in opposition (one true, the other false). To use stageVideo, please use the
above recommended configuration; to run unit tests, please negate the values.

4. If you want to remove the older version of OSMF that is shipped with Flex 4 SDK, select File >
Properties > Flex Build Path > Library path, select osmf.swc under Flex 4.1 SDK on the Library
Path panel, and click the Remove button.

Using OSMF in Flash CS5
1. Download latest Flex Hero build from
http://opensource.adobe.com/wiki/display/flexsdk/Download+Flex+Hero




7.

Close Adobe Flash CS5 application

Go to {Adobe Flash CS5 install directory}/Common/Configuration/ActionScript 3.0 ( for ex:
C:\Program Files (x86)\Adobe\Adobe Flash CS5\Common\Configuration\ActionScript 3.0 )

Make a new directory called FP10.2
Copy the playerglobal.swc from [flexherosdk]/frameworks/libs/player/10.2/ to the FP10.2 folder

Duplicate the FlashPlayer10_1.xml from {Adobe Flash CS5 install
directory}/Common/Configuration/Players to FlashPlayer10_2.xml

Modify the first two player arguments from

<player id="FlashPlayerlO" version="10" asversion="3">
<name>Flash Player 10</names

to:

<player id="FlashPlayerl0.2" version="11" asversion="3">
<name>Flash Player 10.2</name>

..to

8.

9.

Modify also :

<playerDefinitionPath
as2="3 (UserConfig) /Classes/FP10;$ (UserConfig) /Classes/FP9;3 (UserConfig) /Classes/FP8;
$ (UserConfig) /Classes/FP7" as3="$ (AppConfig) /ActionScript 3.0/FP10/playerglobal.swc"
/>

<playerDefinitionPath
as2="3 (UserConfig) /Classes/FP10;$ (UserConfig) /Classes/FP9;$ (UserConfig) /Classes/FP8;
$ (UserConfig) /Classes/FP7" as3="$ (AppConfig) /ActionScript
3.0/FP10.2/playerglobal.swc" />

Open Adobe Flash CS5 and in the publishSettings select FlashPlayer10.2

10. Compile



NOTE: To run OSMFTest (unit test suite) include the following files in your project library folder:

e  FlexUnit.swc
e  FlexUnitOptional.swc
e NetMocker.swc

You may also need to update the SWC file path when you import the OSMFTest project.

Sample Applications

There are a number of sample applications provided which demonstrate new and old features. Each
sample application is located in apps/samples/framework (for framework samples), apps/samples/libs
(for library samples), or apps/samples/plugins (for plug-in samples). The root directory of each sample
project holds a readme.txt file with installation and usage instructions.

Sample apps include:

AkamaiPluginSample:

Demonstrates the use of plug-ins. Integrates with other OSMF-provided plug-ins (SMIL, captioning,
Akamai, etc.).

CaptioningSample:

Demonstrates loading the OSMF captioning plug-in and using an external captioning

document to show captions over a video. Specifically, the sample app loads the OSMF captioning plug-
in, places the URL location of a WC3 Timed Text DFXP file on the metadata of the video resource, and
listens for the metadata TemporalFacet to be added to the VideoElement. When the TimelineMetadata
is added to the VideoElement, an event listener is added for events of type TimelineMetadataEvent. In
that event handler, the caption data is included in the event and the sample app renders the caption
using the style information found in the caption object that was passed to the event listener.
ControlBarPluginSample:

Demonstrates how to create a visual plug-in. In this particular example, the visual plug-in encapsulates
a video control bar which controls playback of the video, and which is laid out using OSMF’s layout
system.

CuePointSample:

Demonstrates cue point support in OSMF.
DVRSample:

Demonstrates DVR support in OSMF.
DynamicStreamingSample:

Demonstrates dynamic streaming support in OSMF.
ExamplePlayer:

Demonstrates playback of a wide variety of media.
HelloWorld:

Demonstrates the simplest possible application that can be built with OSMF (see HelloWorld.as).
HTMLMediaContainerSample:

Demonstrates how to use the HTML Bridging feature.
LayoutSample:

Demonstrates how to use the Layout feature in OSMF.
MASTSample:



Demonstrates the use of the MAST ActionScript plug-in to retrieve a MAST document, parse it into a
MAST object model, and play a pre-roll ad before a video. This sample integrates with the VAST library,
which only support VAST 1.0.

MASTSampleNew:

Demonstrates the use of the MASTPluginNew ActionScript plug-in to retrieve a MAST document, parse it
into a MAST object model, and play a pre-roll ad before a video. This sample integrates with the
VASTNew library, which supports VAST 1.0 and VAST 2.0.

MediaContainerSample and NestedMediaContainersSample:

Demonstrates part of the framework's media container feature which allows media elements to be
routed.

MediaPlayerSpriteSample:

Demonstrates the use of MediaPlayerSprite.

OSMFPlayer:

Defines an application that can be embedded on a web page in order to play back media. It contains a
control bar that manages the various supported aspects of the media. It also uses the Chromelibrary,
which serves as a reference on implementing a user interface for an OSMF based player.
TransitionsSample:

Demonstrates the use of visual transitions within an OSMF application.

VASTSample:

Demonstrates the use of the VAST ActionScript library to retrieve a VAST document, parse it into a VAST
object model, and generate one or more MediaElements that correspond to the playback instructions of
that VAST document. Note that the VAST library only supports VAST 1.0.

VASTNewSample:

Demonstrates the use of the VASTNew ActionScript library to retrieve a VAST document, parse it into a
VAST object model, and generate one or more MediaElements that correspond to the playback
instructions of that VAST document. Note that the VASTNew library supports both VAST 1.0 and VAST
2.0.

VPAIDSample:

Demonstrates the use of the VPAID library.

Note: Flex 4.1 or higher is recommended to run the Flex sample applications.

Compatibility
Flash Player 10.2 is required.

Known Issues

e http://bugs.adobe.com/jira/browse/FM-1316 - Seek to live on MBR LIVE with DVR stream,
occasionally doesn't work

e http://bugs.adobe.com/jira/browse/FM-1315 - On playback complete, 2 stream fragments get
buffered instead of 1

e http://bugs.adobe.com/jira/browse/FM-1314 - Calling canSeekTo API for a LIVE stream throws a
RTE

e http://bugs.adobe.com/jira/browse/FM-1313 - [Late binding audio] Switching back to default
audio stops playback




e http://bugs.adobe.com/jira/browse/FM-1299 - [Late binding audio] Audio and video tracks on
LIVE HDS are greatly out of sync

e http://bugs.adobe.com/jira/browse/FM-1298 - [Late binding audio] Audio stream begins
playback 2 seconds after video has begun playback

e http://bugs.adobe.com/jira/browse/FM-1259 - [Late binding audio] In a LIVE scenario, switching
to an alternative live stream that is not yet up and streaming causes an error and stops video
playback of main media track

e http://bugs.adobe.com/jira/browse/FM-1247 - [Late binding audio] Playback of a f4m file that
has the main media longer than the alternate audio track beeing used leads to a browser crash /
hang

e HTTP Streaming certification unit tests require Flex 4 to compile. To use Flex 3 environment for
the HTTP Streaming player change htmlPlayerVersion to “10.0.0" to avoid Compiler error.

e OSMFIntegrationTest — A few integration tests will fail because they require access to the Adobe
network.

Documentation
The API Reference and the OSMF Developer’s Guide (browsable HTML versions) are available on the
open source site here: http://opensource.adobe.com/wiki/display/osmf/Developer+Documentation

A zipped version of the API Reference is also available on the Downloads section of the open source site
here: http://opensource.adobe.com/wiki/display/osmf/Downloads

The Plug-in Developer’s Guide is available on the Developer Documentation section of the open source
site here: http://opensource.adobe.com/wiki/display/osmf/Developer+Documentation




